Category Archives: rant

Old Tech Perservance

Success! But it was hard won…

Ages ago I bought two MOTU 828 interfaces to connect my modular synth to my main Mac, which uses the MOTU AVB interfaces – a 1248 and a 16A. While the AVB interfaces were easy to connect up, getting my head around the patching took some work… And by work I mean perseverance. In that case I ended up plugging a drum machine in and tracing it through the virtual routing until I had everything patched as I wanted. I then added a first 828, using it in free standing A/D mode as its sitting by modular synth and the easiest cabling to my other interfaces was to get some long ADAT/fibre cables. I got it connected and working but it took some perseverance, since the 828 also needs to follow the master clock. I did that a year or two ago… and promptly forgot what a fckng hassle it is…

Yesterday, after putting it off for ages, I decided I’d connect the second 828 via the same process. That way I can record 16 channels of modular direct to DAW. Four hours later I was beginning to lose the plot as I thought I had the two 828 interfaces set up exactly the same. I did not. I had forgotten that the first time I did this I followed the steps in an article, and this time I was just trying to logic it out…

About 11pm last night I finally used the right search term & found this article:

Using a MOTU audio interface as a standalone A/D or D/A converter

I had forgotten that it is a unique/non-standard use for these interfaces, and is not possible to enable just by using the front panel controls on the interface. First I tried connecting my ancient laptop to the 828 via USB but it would not recognise it at all, no matter what drivers I installed. Such was my frustration, at this point I tried connecting via firewire! Finding the cables & adaptors was a challenge but I got them, connected up & nothing…

Two bourbons later I thought I’d check if its supported to connect my little M2 laptop to this ancient interface via USB and I was surprised to discover it was!! Next I had to install new MOTU drivers etc to my M2 laptop which required jumping through some hoops… ie relogging into my laptop & setting it to ‘less secure’ mode to allow driver install. And of course my M2 laptop does not have old USB so I connected via a hub, hoping it would still see it. I rebooted & sucecss!

About midnight I had sixteen channels of modular rattling the walls & I zoned out for another few hours, enjoying the ad hoc patch I built for testing…

Success!!

 

 

All of this is simply to reshare that article.
I don’t think I would ever have worked out how to get the old 828 interfaces to do what I wanted without it, the process is very non-intuitive. So if someone finds this by googling ‘MOTU stand alone routing 828 interface’ or something, then please go read this article & follow the steps carefully:

Using a MOTU audio interface as a standalone A/D or D/A converter

So my setup now looks AND works like this:

56 inputs!

Running 4 ADAT cables is much easier than audio cables, but ideally it would all be AVB and then its as easy as a typical basic Ethernet network… Of course there are limitations with the old 828 interfaces. They are DC coupled, so I can use them for CV although thats not the primary aim. But to get all sixteen channels across via ADAT the sample rate limit is 48k. If I use 96k then the number of channels across ADAT halves, so I’d still have 8 channels at 96kHz eg for higher rez sampling.

Next project to implement:
I bought a SOMA Illuminator last year, which basically enables using 8 channels of CV to control LED lights (or DC motors etc) so I am going to connect it up as an experiment ‘visualising’ some of my modular patches. I’m sure my first test will be a Ryoji Ikeda style stroboscopic overload, but I am intrigued to try with some smaller LED installs. For example imagine putting short sections of LED lights inside glass objects or some other kind of visual diffuser… Eight channels is enough to visualise a step sequencer or individual drums from a beat…. The idea of controlling (& sequencing!) DC motors or any other kinds of DC activated devices is deeply intriguing…

A demo by SOMA:

ILLUMINATOR live performance demo (SOMA labs)

ILLUMINATOR live performance demo (SOMA labs)

 
 

UPDATE: One link worth saving: I could not work out how to monitor both my DAW output & my Internal Mac sound output at the same time. I had been using an external mixer for this, so with it I’d run output from 1248, output from Mac and output from my turntables into a mxier, and the xmier went to my JBL speakers. I decided I wanted to eliminate the external mixer, so I’ve plugged the Mac outptus into the guitar inputs on the 1248. And then following this advice in a reply from MOTU tech support in this forum post:
https://www.motunation.com/forum/viewtopic.php?t=59826
“The only way is to use the seperate mixer built into each MOTU interface…

 

 

Avid Link

So I’m busy working & have my usual bunch of apps open – ProTools, RX, Scrivener, Email… And suddenly my Mac UI starts going slow like its about to crash…. WTF I have 64GB of RAM, it can’t be the apps… So I boot up Activity Monitor and WTF?

AvidLink, which I have zero use for, is using 96.6% of my Macs CPU!
I Force Quit it and my Mac becomes responsive again…
My next thought: can I delete AvidLink? What use is it?

“Avid Link is a free app for anyone looking to find, connect, and collaborate with other creatives,
promote your work, stream video, purchase and manage products—all in one interface”

No thanks.
But rather than delete it, for now I’ll follow this advice of how to stop it auto-launching
Stop Avid Link from starting at boot

This default of forcing us to have a cloud connection is so tedious, inefficient & tone deaf.
Maybe, just maybe we don’t fckng want banal notifications popping up while we concentrate on actual work!

Similarly the Adobe Creative Cloud app on my Mac keeps displaying a red warning.
Why? Because I deliberately have “Libraries Syncing” to their cloud disabled.
Because I have no use for it.

Stop Adobe Creative Cloud from starting at boot